Friday, February 15, 2008

Transcode 360 was unable to transcode [path to folder]

I am using Transcode 360 version 1.6.3 on Vista MCE to stream backed up movies (DVD) to a Xbox 360 extender. Many movies work, but many movies do not. The one's that don't work display the error 'Transcode 360 was unable to transcode [path to folder]'.

The T360 log file shows this for the error portion (on Vista the log files are located at 'C:\Users\Public\Transcode360\Logs'):
2/15/2008 2:27:16 PM *VRB* MEncoderTranscoder loaded
2/15/2008 2:27:16 PM *VRB* VLCTranscoder loaded
2/15/2008 2:27:16 PM *VRB* Using optimal resolutions
2/15/2008 2:27:16 PM Spawning: "C:\Program Files\Transcode360\Wrappers\MEncoderTranscoder\mencoder.exe" -quiet -delay 0.5 -oac lavc -srate 48000 -af lavcresample=48000 -of mpeg -mpegopts format=dvd -o "C:\Users\Public\Transcode360\TranscodeBuffer\TheMarsh.360" -ovc copy dvd://1 -dvd-device "\\Vista-mce\G\Movies\TheMarsh\VIDEO_TS"
2/15/2008 2:27:31 PM *ERR* Transcoding error:
2/15/2008 2:27:31 PM *ERR*
WARNING: OUTPUT FILE FORMAT IS _MPEG_. See -of help.

2/15/2008 2:27:31 PM *WRN* MEncoderTranscoder unable to handle request: \\Vista-mce\G\Movies\TheMarsh\TheMarsh.vol
2/15/2008 2:27:31 PM *WRN* Failed to start transcoding
Even though the path is a UNC the files are local to the MCE machine.

I think I found a solution to this problem. I downloaded the MPlayer 1.0rc2 Windows version of mplayer from http://www.mplayerhq.hu and replaced the mencoder.exe file located at C:\Program Files\Transcode360\Wrappers\MEncoderTranscoder with the newer one downloaded from the mplayerhq site. I then ran the configuration utility and double checked that MEncoder was the selected encoder and then stopped and started the service (not sure if that was necessary). Now, all the movies that would not play before will play. These are all .vob files from backed up dvds. Each movie has its own folder, with the .ifo and .vob file contained within a Video_TS subfolder.

3 comments:

Todd said...

Tobin,

great posts. I have followed your examples to the letter. Still having an issue. here is my synopsis.

Todd-PC running:
Media Center fully patched to Date
MyMovies2
DSM-750 Extender

DVD's ripped to VoB's play fine on pc (as usual)

I followed instructions for Transcoder360. Installed w/o any problems.. set up as service lica account
Downloaded latest Mplayer mencoder.. lists as File Version 0.0.9.0 product version 1.0rc2-4.2.1

When I watch stream I get the same error as you did above.. here is a paste from my logs:

5/29/2008 9:11:09 PM Starting Transcode360 service (1.6.3.0)

5/29/2008 9:11:09 PM Loaded configuration settings
5/29/2008 9:11:10 PM Transcode360 service started
5/29/2008 9:12:44 PM Transcode360 SAO (1.6.3.0) created
5/29/2008 9:12:44 PM Transcoding from beginning
5/29/2008 9:12:44 PM Starting transcoding process
5/29/2008 9:12:44 PM *VRB* Retrieving source stats:
5/29/2008 9:12:44 PM *VRB* Output: 'FFmpeg version CVS, Copyright (c) 2000-2004
Fabrice Bellard
configuration: --enable-mingw32 --enable-memalign-hack --extra-cflags=-I/usr/
win32/include --extra-ldflags=-L/usr/win32/lib --prefix=/usr/win32 --cc=gcc -mno
-cygwin --enable-faac --enable-mp3lame --enable-pp --enable-gpl --enable-theora
--enable-libogg --enable-a52 --enable-vorbis --enable-faad --enable-x264 --enabl
e-dts
libavutil version: 49.0.0
libavcodec version: 51.8.0
libavformat version: 50.4.0
built on Apr 4 2006 22:32:07, gcc: 3.4.4 (cygming special) (gdc 0.12, using d
md 0.125)
\\TODD-PC\Movies\Bad_Boys_2\VIDEO_TS.IFO: Unknown format
'
5/29/2008 9:12:44 PM *VRB* MEncoderTranscoder loaded
5/29/2008 9:12:44 PM *VRB* VLCTranscoder loaded
5/29/2008 9:12:44 PM *VRB* Using optimal resolutions
5/29/2008 9:12:44 PM Spawning: "C:\Program Files\Transcode360\Wrappers\MEn
coderTranscoder\mencoder.exe" -quiet -delay 0.2 -oac lavc -srate 48000 -af lavcr
esample=48000 -of mpeg -mpegopts format=dvd -o "C:\Users\Public\Transcode360\Tra
nscodeBuffer\VIDEO_TS.360" -ovc lavc -vf scale=0:0,expand=640:352,harddup -lavco
pts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=9800:vbitrate=8000:keyint=15
:aspect=16/9:acodec=mp2:abitrate=320 -ofps 24000/1001 "\\TODD-PC\Movies\Bad_Boys
_2\VIDEO_TS.IFO"
5/29/2008 9:12:59 PM *ERR* Transcoding error:
5/29/2008 9:12:59 PM *ERR*
WARNING: OUTPUT FILE FORMAT IS _MPEG_. See -of help.
============ Sorry, this file format is not recognized/supported =============
=== If this file is an AVI, ASF or MPEG stream, please contact the author! ===
Cannot open demuxer.

5/29/2008 9:12:59 PM *WRN* MEncoderTranscoder unable to handle request: \\TODD-P
C\Movies\Bad_Boys_2\VIDEO_TS.IFO
5/29/2008 9:12:59 PM *WRN* Failed to start transcoding


Any Suggestions?

Anonymous said...

This works brilliantly. Took about 5 minutes to setup and bingo!

Thanks for posting this guide!

toby said...

Glad it worked for you. I also appreciate that you let me know at least some people are having success with this.

toby.